JW Language is compatible with the following devices:

  • Android tablets and phones (running version 4.1 or later)

Support for the following devices is coming soon:

  • Kindle Fire HD

Support for the following devices is not planned:

  • Android tablets and phones running version 4.0 and earlier

  • Kindle Fire